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__________________________________________________________________________________

Hi! Thank you for downloading Animated Glitch 2 from Envato. This guide will cover the installation 
process and usage of the action set. You may also want to watch the video tutorial at this link: 
https://youtu.be/2xkGICtmauk

Notice that the video tutorial doesn’t include the last part of this guide (Additional Information), make
sure you have a look at it as it contains some useful details about the customization of the file.

If you need any further help do not hesitate to contact me through my profile page on Graphicriver.

If you like this product please leave a review in your download section, link here. 
For more Photoshop tools and templates check my portfolio on Envato Market or Envato Elements.

_________________________________________________________________________________

FEATURES
__________________________________________________________________________________

 Very easy to install and use, user friendly workflow.
 The animation is easily modifiable after the playback, make lots of variations in few clicks.
 Decide the duration of your output.
 Well organized layer structure, easy to read, color-coded and grouped.
 Video tutorial and detailed text guide.
 Compatible with all the CC versions of Photoshop.
 Multilingual, compatible with any language of Photoshop.
 This plug-in is designed to create content with a resolution that is within 100 and 2,500 pixels 

(full HD resolution, 1920x1080 pixels, is within this recommended range).

__________________________________________________________________________________

https://youtu.be/2xkGICtmauk
https://elements.envato.com/user/BlackNull/add-ons
https://graphicriver.net/user/blacknull/portfolio
https://graphicriver.net/downloads
https://graphicriver.net/user/blacknull
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__________________________________________________________________________________

HOW TO USE THE ACTION SET
__________________________________________________________________________________

INSTALLATION

Open Photoshop and the actions panel (Window > Actions). In this panel, click the menu icon at the 
top right corner, select Load Actions and select the file Animated Glitch 2 - Action from wherever you 
downloaded it to.

__________________________________________________________________________________

IMAGE SETUP AND REQUIREMENTS

Open an image to work with. Before using the action, the only thing that requires a setup is the 
resolution and aspect ratio of the image. Go to Image > Image Size, and check this requirements:

Width and Height
Set the exact resolution you need the final output to be. The recommended resolution is from a 
minimum of 100 pixels up to 2000-2500 pixels for each axis of the image. Make sure in the Image Size 
panel that the Width and Height parameters are in this range. 
The action was tested and works also with 4k images (4000+ pixels), but it’s not recommended to 
work with such resolutions. The workflow slows down significantly and the action is “calibrated” to 
give the best results with 2k or lower resolution content. 

So, if you’re creating a video it could be at 1080p resolution (1920x1080 pixels) or if it’s an animated 
banner it could have any aspect ratio and resolution within the recommended range (for example 
600x200 pixels). As a first test start with a small/medium resolution image.

Resolution
In the same panel make sure also that the image is at 72 pixel/inch. The action works at any ppi 
setting, but during the playback it will use the parameters of the resolution to create some of the 
effects, so setting 300 pixel/inch will simply give a different result. Setting 72 pixel/inch guarantees an 
outcome with the sharpest details at the end, but feel free to experiment after the first test.

Cropping and Aspect Ratio
You can use the Crop tool to set the right aspect ratio and cropping of the image. Select the Crop tool 
by pressing C on the keyboard. On the top option bar click the Clear button, activate the Delete 
Cropped pixels option and insert the desired Width and Height values in the first two empty fields. 
Now that the tool is locked on the right proportions use its bounding box to move and scale it as 
preferred, press Enter to apply the changes and crop the image. 
Then open the Image Size panel and insert the right parameters.



White Background
This action won’t work well on images that have a big portion that is 100% white (for example a small 
colored logo on a white background). All the effects based on colors and lights won’t be visible on a 
completely white background. A light gray color will be enough to make these effects visible.

__________________________________________________________________________________

RUN THE ACTION

Before applying the effect, make sure there is only the layer of the image in your file and that it’s 
selected. If you want, you can open the Timeline before the playback from Window > Timeline.

Open the Actions panel, select the Animated Glitch 2 action and click the play icon. The playback time 
can vary depending on the level of detail and resolution of the image and the processing power of 
your computer; for a 1,000-pixel image, it should be a couple of minutes.

When the playback finishes the message Render Completed will appear; click Continue to close it.

See in the layers panel the newly generated layers and groups. By opening the yellow group Digital 
Noise you’ll notice that all the layers inside have a Color Overlay layer style, and by default each style 
is expanded. You can use the arrow on the right of each layer to open and close them one by one. 

Instead, to organize the whole layer tree quickly, hold Alt on your keyboard and close the main group 
ANIMATED GLITCH 2 by clicking its arrow icon. Then release Alt, open the main group again and also 
Digital Noise, notice that all the layers are now re-organized. The fx symbol on the left pf each one of 
these layers indicates that they have a layer style. 

This method can be used to re-organize the layers also in the Timeline of Photoshop.

__________________________________________________________________________________

WATCH THE RESULT

Go to the Timeline and click the Play button at the top left of this panel to watch the animation. The 
first playbacks will be slow because Photoshop needs to cache the frames of the animation before 
making a smooth playback.

The animation is made of 100 frames at 25 frames per second, for a total of 4 seconds.

__________________________________________________________________________________



__________________________________________________________________________________

OVERVIEW AND USE OF THE FILE
__________________________________________________________________________________

THE TIMELINE PANEL OF PHOTOSHOP

Here are few quick tips about the Timeline of Photoshop: 

- Click the menu icon at the top-right of the Timeline and disable Auto-Grouping of Clips. This will 
prevent Photoshop from creating undesired Video Groups when moving the effects in the timeline.

- In the same menu of the Timeline select Panel Options. Here set the Timeline Units to Frame 
Number and select a Thumbnail size that will make your editing phase comfortable.

- Use the Spacebar to play and stop the animation you can also drag the cursor of the Timeline to 
manually decide which part of the animation to watch. 

- Set the Timeline of Photoshop in looping mode by clicking the gear icon on the top-left of the panel 
and activating Loop Playback. The Resolution parameter visible in this menu refers to the resolution of
the preview during the playback of the animation. 

- Adjust the zoom level of the Timeline from the slider on the bottom of the panel.

__________________________________________________________________________________

LAYER STRUCTURE

In the Layers Panel open the main group Animated Glitch 2. All the effects are organized in five 
subgroups and a Base layer which is just a copy of the original image:

 Post FX
 Chromatic Effects
 Digital Noise
 Glitches
 Base FX
 Base

All the effects are organized in the four bottom groups (Base FX, Glitches, Digital Noise, Chromatic 
Effects) they contain several layers and each one is basically an animated effect. 
Post FX, on the other hand, contains some layers for the final tweaks and color adjustments.



Open the main group Animated Glitch 2 also in the Timeline. The organization of the groups and layers
is the same as in the Layers Panel, but notice that when opening one of the subgroups (start with Base
FX) the layers inside are shown as clips.

Most of the effects of Animated Glitch 2 are packed into clips that make the customization of the file 
easy and organized. A clip could be very short because it contains a quick and flashy effect of just few 
frames or be a long clip with an effect that covers the entire work area. 

A good thing to do now is to hide all the groups in the Layers Panel and play the animation keeping 
only Base FX visible. Then do the same also for the other groups, this way you’ll have a clear idea of 
how each category of effects is contributing to the final result.

__________________________________________________________________________________

BASIC CUSTOMIZATION GUIDE

__________________________________________________________________________________

It’s possible to quickly create many variations from the original animation by following the few simple 
methods listed below. Most of the editing is done with just two panels, the Timeline to decide the 
timing of the effects and the Layers Panel to decide their appearance. 

Make a Snapshot: Before editing the file you can make a Snapshot of it. Open the History Panel from 
Window > History, click its menu icon at the top left and select new Snapshot, then click OK. The 
snapshot will save the current history state. If you make variations to the file and want to reset it to 
this default state, you can do it by simply clicking the Snapshot in the History Panel.

Hide Effects: After the playback of the action all the effects are visible by default and often it’s not 
necessary to use them all in order to create a nice animation. You can hide effects in the layers panel 
by clicking the eye icon of each layer.

Move the effects horizontally: Each effect can be moved in the Timeline by just dragging its clip, this 
way it’s possible to totally change the order in which the effects are appearing and how they combine 
with each other.

When doing this step consider that in the two bottom groups (Base FX and Glitches) the layers by 
default are not transparent and are in Normal blending mode. If the layers of these two groups 
overlap with each other only the one on top will be visible.
Make sure to spread the clips of these groups on the timeline avoiding big overlaps.



It is not an issue if these effects overlap for just few frames, the animation will “jump” from one effect 
to the other, often making it look like another glitch effect.

An exception are the top three layers of the Glitches group, Lines 1-2-3. This set of layers are in normal
blending mode, but have transparency and can be overlapped with all the other effects.

The layers in the other groups instead are all in different blending modes and have some transparency.
When these layers overlap with other or the layers of Base FX and Glitches, they will blend and create 
a combined effect.
Try changing the position of all the effects randomly leaving just the group Post FX for later.
This step already offers a lot of potential of customization. By matching, syncronizing and overlapping 
different types of effects it is possible to create a great amount of alternative animations.

Blend the effects: The Blending Mode and Opacity of all the layers and groups generated by the action
can be modified to decide how they combine with each together. Also the effects of Base FX and 
Glitches can be mixed by changing these two parameters.

If the Blending Mode and Opacity of a clip is grayed out n the Layers Panel, it is because the cursor of 
the Timeline has to be positioned were the clip is. The same rule applies also to the other types of 
editing tools like Transforms. You can also double click the layer and change the two parameters, 
blending mode, and opacity from the Layers Style Panel.
With this plugin there isn’t a best combination of blending modes to suggest, the best thing is to try 
them all. It really depends on the image you’re using and the result you want to achieve.

Move the effects vertically: You can move individual layers or entire groups up and down in the Layers
Panel to achieve different effects. For example the colors of the effects in the yellow group are 
affected by the effects in the orange group (Chromatic FX is all about color shifts and changes). You 
can manually position the yellow group above the orange one, so that its colors won’t be affected. 
Similar operations can be done all over the layers tree to achieve different results.

Duplication and Transform: In the Layers Panel you can duplicate layers as many times needed and 
distribute the copies in the timeline to repeat that effect multiple times in the animation.
To do it use the command Duplicate Layer (Right-click on layer > Duplicate Layer), it will create the 
layer on the exact frame were the original layers is.
Instead the command Layer Copy, Ctrl+j (Windows) or Cmd+j (Mac), will create the new layer were 
the cursor of the Timeline is positioned.

You can move, scale and rotate layers with the Transform tool. Select a layer and press Ctrl+t 
(Windows) or Cmd+t (Mac) to activate it.

Use the Masks Channels: It’s possible to hide just some parts of an effect using the mask channels.
Select a layer and click on Add Layer Mask at the bottom of the Layers Panel to create a mask channel 
for the layer. With the mask channel selected, select the Brush tool (press B on the keyboard) and 
select black as color. Next paint over the image and the parts you want to hide.
Painting the mask channel with black will hide parts of the layer, you can switch to white color to 
restore again these hidden parts.



Change Colors: You can quickly change the color of some of the effects. As mentioned earlier if a layer 
has an fx symbol, it means that it has a Color Overlay layer style. This can be turned on/off by clicking 
its eye icon and double clicked to choose a custom color. Some other effects are made with Solid Color
layers, double click the thumbnail of these layers to choose a custom color.

Final Touches: Once the editing of the effects is done you can make the final tweaks in the Post FX 
group. It’s very easy to use, the few methods mentioned previously can be applied also here.

For Tint, Grain, Vignetting, Scanlines and Glow it is particularly important to tune the opacity and 
blending mode to make them work with your image and style.
Double click the thumbnail of Tint and Vignetting to change their color. And to increase or decrease 
the softness of the Glow you can edit its Gaussian Blur smart filter.
The top three layers, Hue/Saturation, Levels and Contrast are simple adjustment layers for color 
balancing. 

__________________________________________________________________________________

EXPORT THE ANIMATION

__________________________________________________________________________________

Export as Gif:  You can save it as gif from File > Save As and then selecting .gif as format in this panel.
I personally prefer the Save for Web panel, located in File > Export > Save for Web (Legacy).

The following settings will give a good balance between quality and file size and a starting point to 
make your adjustments.

Type: GIF
Palette: Perceptual 256
Dither: Diffusion 100% (lower dither = lower file size, but less quality)
Transparency: Yes
Lossy: 10 (higher lossy = lower file size, but less quality)
Looping Option: Forever

Export as video: To save a video go File > Export > Render Video, then Select the folder where you 
want to save the video. The Render Video panel can be accessed also by clicking the menu icon of the 
Timeline. As format and preset, try these:
- Format H.264 with Preset High quality, it’ll be a nice quality video and the size will be very small.
- Format QuickTime with Preset Animation High Quality, it’ll be a very good quality video, the file size 
will be bigger.



__________________________________________________________________________________

ADDITIONAL INFORMATION

__________________________________________________________________________________

In this section you will find some additional information that is not covered in the video tutorial. Some
of the procedures listed below require at least an intermediate knowledge of Photoshop. 

Change the length of the animation: You can change the length of the animation by just dragging the 
end point of the Work Area bar in the Timeline. Making the animation shorter is no issue, but to make 
it longer, drag manually the gray Base layer to the desired length and the end point of the work area 
will follow it automatically. Next you’ll have to manually extend to the desired length also all the layers
in the Post FX group.
Notice that Grain cannot be extended like the other layers of the Post FX group because it’s a smart 
object. This introduces the next section.

Smart Objects: Most of the effects are smart object layers, you can double click their thumbnail to 
manually edit the layers inside.
For example Grain is a smart object that contains several noise clips of 10 frames each. When 
increasing the default length of the animation, remember to duplicate the clips inside Grain as many 
times needed to make it cover the whole length of the animation.
Grain is just one example, other smart objects can contain layers with key frame animations that can 
be entirely modified. Also remember that each single effect/clip can be manually animated in the 
Timeline of Photoshop (transform, opacity and style are the available parameters).

Create and export still images: To create cool still images with glitch effects, you can take frame zero 
as the master frame and move all the desired effects on it; creating this way a composition with 
multiple effects blended together. Use one effect at a time deciding which editing methods to apply on
each one. Once done save the image in your preferred format from File > Save As.

Use images with transparency: Open any image that has transparency, make sure that it’s the only 
layer in your file and that it’s selected (this should be done always), then run the action normally. The 
action will generate an output preserving the transparency features, then you can manually place a 
background that could be a solid color, a photo or a video.

Make glitch transitions: The transition between two different images shown in the examples is made 
by simply applying the action separately on two images and exporting two different videos. Each video
has a “strong” glitch effect positioned at around frame 50. Then these videos are edited together in a 
third Photoshop file with a transition at frame 50.
It’s important to use separate files and to not apply the action twice to the same file!



Use in combination with Animated Glitch 1: To use the effects of this add-on in combination with 
Animated Glitch 1 simply apply the two actions on two separate files, then drag and drop the desired 
clip/effects from one file to the other. Holding shift on the keyboard while dragging the layer, it will be 
automatically centered on the canvas of the host file.
You can also drag and drop the entire output folder (layers tree) of an action instead of single clips, 
just remember to delete the Base layer of the output folder on the top because being it a solid 
background and it would cover the effects below.

__________________________________________________________________________________

DETAILS ABOUT EFFECTS

Here are some details about the effects in the yellow and orange groups that could be useful during 
the editing phase.

Digital Interference: The two Digital Interference effects by default have a length of 20 frames each, 
but they can be extended by dragging their In or Out points to a total length of 100 frames. Double 
click the thumbnail of one of these two layers to open the smart object and see how this effect is 
composed.

Color Negative: Both these layers are in difference blending mode by default, but they can work very 
well in other blending modes too. You can duplicate it many times to create a sort of strobe-like effect.

Stripe: If you need to enhance the visibility of the layers Stripe 1-2 try them in other additive blending 
modes like Linear Dodge. Both layers are smart objects and inside they contain a key frame animation 
that can be edited.

Chromatic Aberration: It’s important to adjust the blending mode of the Chromatic aberrations to 
make them work well with your image. You can select which channels of the layer are visible from the 
Layers Panel, double click the layer and in the main section of the layers panel select which RGB color 
is visible.. Double click the smart object to modify the animation.

__________________________________________________________________________________
Thank you for the attention! For more digital goods visit: www.graphicriver.net/user/blacknull

https://graphicriver.net/user/blacknull

